Artist Series bugs

This category is for bug reports on Artist Series controllers.
You can view open issues ranked by Votes, Newest, etc.
See the Instructions Page for more info.

Artist Series bugs

MC Mix bug with Logic Pro X 10.3.1

Check you select a Aux channel in Logic's mixer then select Aux button on MC MIX - when you go into Channel mode you can not turn off individual inserts for the selected aux channel.

(OSX 10.12.3)

Submitted by (@dowdag)
Add your comment

Opertaing System(s) : macOS 10.12

Voting

-2 votes

Artist Series bugs

Eucon 3.5 artist lock doesn't work properly

Using 1 transport and 2 artists. If I lock the artists to an application, it locks the transport as well. When I deselect the transport I can use it in another application, but eucontrol doesn't remember it being deselected. So after a reboot I have to deselect the transport again when using the same app I have locked the artists to. It remembers all or nothing.

Submitted by (@jjdekker)
Add your comment

Opertaing System(s) : Windows 10

Voting

4 votes

Artist Series bugs

Eucontrol Sends functionality lost in MioConsole

After Updating to latest MIOConsole (5.6.09.221) and EuControl (ver. 3.5) I seem to have lost the ability to access the sends window of the MioConsole Mixer on my McMIX?? From MobileIOUserGuide: "To Select the Sends bus (or move to the next Send bus) on MC Mix Simultaneously press the MC Mix SHIFT and PREV buttons” This functionality seems to have stopped working. Also if I press the ”AUX” button on McMIX I get my ...more »

Submitted by (@anssilaiho)
Add your comment

Opertaing System(s) : OS X 10.11

Voting

1 vote

Artist Series bugs

Rotary knob #1 on Artist Mix does not work in Logic Pro 10.2.4

When using Logic Pro 10.2.4 with Artist Mix 3.4, the first encoder knob push top works fine to select but rotating the knob has no effect. Ie. pan does not adjust.

Submitted by (@john007)
1 comment

Community Discussion Link : http://duc.avid.com/showthread.php?t=383362

Opertaing System(s) : OS X 10.11

Voting

2 votes

Artist Series bugs

Certain faders and encoders randomly stop working.

I have noticed recently that while working in Pro Tools, some of the faders and rotary encoders will randomly stop responding to touch. Banking over and back again occasionally fixes the issue, but not always. I have used the hardware test mode to verify that this is not a hardware issue.

Submitted by (@aaron.meier)
Add your comment

Opertaing System(s) : OS X 10.10

Voting

2 votes

Artist Series bugs

Clicking rotary encoder resets send level.

In Aux mode, with Flip engaged, when clicking a rotary encoder to access additional parameters for a send (pan, etc.)., the send level resets to -inf.

Submitted by (@aaron.meier)
Add your comment

Opertaing System(s) : OS X 10.10

Voting

2 votes

Artist Series bugs

Sel button not working correctly in AUX mode.

In Aux mode, with Flip engaged, the Sel button does not change from lit to unlit when changing a send from pre to post or vice versa. Banking the Artist Mix fader out of view and back again resets the button to the correct state.

Submitted by (@aaron.meier)
Add your comment

Opertaing System(s) : OS X 10.10

Voting

2 votes

Artist Series bugs

Avid Artist Series mixers and Eucon Software

Avid have changed plugin mappings on the artist series controllers with EQIII and Chanel Strip beginning in protools 11 and on, that's all I've personally noticed; this might have happened with other Avid plugins as well! In protools 10 we'd have access to freq/gain/Q all on one page and now in 11 and up Q is only accessible when you hold down the shift key and touch the frequency knob or if your working in plugin flip ...more »

Submitted by (@coryrizos)
Add your comment

Opertaing System(s) : OS X 10.8

Voting

13 votes

Artist Series bugs

Eucon 3.2.2 incompatible with Logic 10.1.1

Everytime I restart my Mac Pro I have to reinstall Eucon 3.2.2, otherwise Logic 10.1.1 crashes during startup while "starting up eucon support".

Submitted by (@florianleissle)
1 comment

Opertaing System(s) : OS X 10.10

Voting

4 votes

Artist Series bugs

MackieControl Emulation

http://www.avid.com/US/products/Artist-Mix/features it says, "Supports EUCON, HUI and Mackie Control protocols" While the faders/mutes all work with recording and motorized playback, - 0 dB in the DAW places the fader between the 0 and 6 positions, not at 0. - It's not possible to navigate the faders to control return channels or the Master channel. - Only Channel 1 shows any VU-Meter. I believe the level shown reflects ...more »

Submitted by (@adam.m)
2 comments

Community Discussion Link : http://duc.avid.com/showthread.php?t=354097

Voting

20 votes

Artist Series bugs

View Rulers shouldn't take me off the edit screen

When you want to add a ruler or take one out of view, it will automajically change you off the edit screen.

 

THe edit screen is where you view the rulers....so you have to switch back to the edit screen to see the original view that you were adjusting.

Submitted by (@yyr123)
Add your comment

Voting

5 votes

Artist Series bugs

Shift Alt/Option commands not working on the surface.

The normal shift alt/opt commands to not work from the surface. Example...you want to change all the outputs on several tracks. It's usually done by selecting all tracks Shift alt/opt key then change the output on one of the tracks....... This doesn't work from the surface but does via the keyboard short cuts... I will also throw this in there as well......while on my windows laptop it is showing the mac softkeys....It ...more »

Submitted by (@yyr123)
1 comment

Voting

7 votes