Artist Series bugs

This category is for bug reports on Artist Series controllers.
You can view open issues ranked by Votes, Newest, etc.
See the Instructions Page for more info.

Artist Series bugs

Link to Artist download page in Eucontrol menu wrong

When you click on "Artist Series Download page" in EuControl's Help menu you are taken to a nonexistent page on the avid site. Result: 404 Page not found.

Submitted by
Add your comment

Voting

3 votes

Artist Series bugs

Sel button not working correctly in AUX mode.

In Aux mode, with Flip engaged, the Sel button does not change from lit to unlit when changing a send from pre to post or vice versa. Banking the Artist Mix fader out of view and back again resets the button to the correct state.

Submitted by (@aaron.meier)
Add your comment

Opertaing System(s) : OS X 10.10

Voting

2 votes

Artist Series bugs

Clicking rotary encoder resets send level.

In Aux mode, with Flip engaged, when clicking a rotary encoder to access additional parameters for a send (pan, etc.)., the send level resets to -inf.

Submitted by (@aaron.meier)
Add your comment

Opertaing System(s) : OS X 10.10

Voting

2 votes

Artist Series bugs

Certain faders and encoders randomly stop working.

I have noticed recently that while working in Pro Tools, some of the faders and rotary encoders will randomly stop responding to touch. Banking over and back again occasionally fixes the issue, but not always. I have used the hardware test mode to verify that this is not a hardware issue.

Submitted by (@aaron.meier)
Add your comment

Opertaing System(s) : OS X 10.10

Voting

2 votes

Artist Series bugs

Rotary knob #1 on Artist Mix does not work in Logic Pro 10.2.4

When using Logic Pro 10.2.4 with Artist Mix 3.4, the first encoder knob push top works fine to select but rotating the knob has no effect. Ie. pan does not adjust.

Submitted by (@john007)
1 comment

Community Discussion Link : http://duc.avid.com/showthread.php?t=383362

Opertaing System(s) : OS X 10.11

Voting

2 votes

Artist Series bugs

Eucon Transport Bars+Beats subcounter cut off

Since the latest firmware update, the bars and/beats sub counter is chopped off by 4 pixels/out of alignment. Really - do you guys even check stuff?

Submitted by (@neilparfitt)
1 comment

Voting

1 vote

Artist Series bugs

Eucontrol Sends functionality lost in MioConsole

After Updating to latest MIOConsole (5.6.09.221) and EuControl (ver. 3.5) I seem to have lost the ability to access the sends window of the MioConsole Mixer on my McMIX?? From MobileIOUserGuide: "To Select the Sends bus (or move to the next Send bus) on MC Mix Simultaneously press the MC Mix SHIFT and PREV buttons” This functionality seems to have stopped working. Also if I press the ”AUX” button on McMIX I get my ...more »

Submitted by (@anssilaiho)
Add your comment

Opertaing System(s) : OS X 10.11

Voting

1 vote

Artist Series bugs

Eucon 3.1 bug

Create a couple of tracks.

Select all tracks

Use artist mix to assign all tracks to a send in send 1

Assign all tracks to another send in send 2.

 

Always leave tracks selected.

 

Remove all sends from send 2.

Remove all sends from send 1... nothing happens.

You have to deselect and reselect for it to work.

Submitted by (@puttekvist)
Add your comment

Voting

0 votes

Artist Series bugs

Eucon crashes on launch

Hello,

 

Version:

 

EuControl 3.7 - Mac OS X

Revision date: Oct 10th, 2017

 

every time I launch EuControl app, it crashes.

 

I have attached one of the crash reports.

 

Thanks

Alex

Submitted by (@alexandroskyrlis)
1 comment

Opertaing System(s) : macOS 10.12

Voting

0 votes

Artist Series bugs

MC Mix bug with Logic Pro X 10.3.1

Check you select a Aux channel in Logic's mixer then select Aux button on MC MIX - when you go into Channel mode you can not turn off individual inserts for the selected aux channel.

(OSX 10.12.3)

Submitted by (@dowdag)
Add your comment

Opertaing System(s) : macOS 10.12

Voting

-2 votes